Aruba OS-CX config example

Aruba, een HPE onderdeel, levert haar switches sinds 2021 met een nieuw besturingssysteem. Daarmee komt er een einde aan configuratie taal waaraan je gewend was. Er is buiten allerlei cli reference guides echter weinig te vinden qua voorbeelden. Vandaar dat ik heb besloten om enkele basis zaken uit te schrijven.

Een van de meest opvallende wijzigingen is het toewijzen van VLAN’s en poorten. In het vorige OS was je gewend om in je configuratie VLAN’s op te nemen, en daarbinnen interfaces (switchpoorten) op te nemen. In het nieuwe OS-CX configureer je in de basis de interfaces (switchpoorten) en vermeld je daarop de VLAN’s.

interface 1/1/1
    description Accesspoint
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30
interface 1/1/2
    description Accesspoint
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30

Wanneer een poort UNTAGGED deelneemt aan een VLAN, is dat je NATIVE vlan. Overige VLAN’s waaraan een poort TAGGED deelneemt configureer je als ALLOWED

Hieronder een voorbeeld configuratie:

hostname SW03
clock timezone europe/amsterdam
ntp server ntp.time.nl minpoll 4 maxpoll 4 iburst
ntp enable
!
!
!
!
vlan 1
vlan 20
    name GUEST
vlan 30
    name DOMOTICA
vlan 40
    name TBA
spanning-tree
interface 1/1/1
    description Accesspoint
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30,40
interface 1/1/2
    description Accesspoint
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30,40
interface 1/1/3
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/4
    no shutdown
    vlan trunk native 30
interface 1/1/5
    no shutdown
    vlan trunk native 30
interface 1/1/6
    no shutdown
    vlan trunk native 1
interface 1/1/7
    no shutdown
    vlan trunk native 1
interface 1/1/8
    no shutdown
    vlan trunk native 1
interface 1/1/9
    no shutdown
    vlan trunk native 1
interface 1/1/10
    no shutdown
    vlan trunk native 1
interface 1/1/11
    no shutdown
    vlan trunk native 1
interface 1/1/12
    no shutdown
    vlan trunk native 1
interface 1/1/13
    no shutdown
    vlan trunk native 1
interface 1/1/14
    no shutdown
    vlan trunk native 1
interface 1/1/15
    no shutdown
    vlan trunk native 1
interface 1/1/16
    no shutdown
    vlan trunk native 1
interface 1/1/17
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/18
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/19
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/20
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/21
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/22
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/23
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/24
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/25
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/26
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/27
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/28
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/29
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/30
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/31
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/32
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/33
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/34
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/35
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/36
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/37
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/38
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/39
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/40
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/41
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/42
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/43
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/44
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,30,40
interface 1/1/45
    description TBA
    no shutdown
    vlan trunk native 40
interface 1/1/46
    description TBA
    no shutdown
    vlan trunk native 40
interface 1/1/47
    description TRUNKPORT
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30,40
interface 1/1/48
    description TRUNKPORT
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30,40
interface 1/1/49
    description TRUNKPORT
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30,40
interface 1/1/50
    description TRUNKPORT
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30,40
interface 1/1/51
    description TRUNKPORT
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30,40
interface 1/1/52
    description TRUNKPORT
    no shutdown
    vlan trunk native 1
    vlan trunk allowed 1,20,30,40
interface vlan 1
    ip address 192.168.20.244/24
    ip dhcp
        ! ip dhcp is ignored when static ip is configured
ip route 0.0.0.0/0 192.168.8.1
ip dns domain-name susse.net
ip dns server-address 8.8.4.4
!
!
!
!
!
https-server vrf default

Vergeet na het configureren niet om je config op te slaan:

write mem

Heb je een bestaande switch en wil je deze terugbrengen naar een factory default configuratie?

erase all zeroize